Release 0.2

So continuing to work on the extension, I needed to use some from the add-on SDK built in to Firefox.  After a lot of research I figured out how to load that module of the SDK and use it to interact with the browser and get the DOM of the page.  After adding this line of code

XPCOMUtils.defineLazyModuleGetter(this, "tabs", "resource://gre/modules/commonjs/sdk/tabs.js");

I built the extension and installed it, but the code had no effect.  Looking at the error log I noticed this

error1

After clicking the tabs.js where the line error is I see this

error2

So the extension itself doesn’t know what module is.  I believe that this is because currently the extension is not made and built with the Firefox add-on SDK.  That’s why I will concentrate on converting the whole extension so far to the new add-on model.   This work has already begun.

Git repo: https://github.com/mbbaig/Publisher/tree/release0.2

Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=917950

Release 0.1: https://mbbaig.wordpress.com/2013/09/26/release-0-1/

Advertisements

2 thoughts on “Release 0.2

  1. Pingback: Release 0.3 « Mohamed Baig's Blog

  2. Pingback: Work on Release 0.3 | Mohamed Baig's Blog

Comments are closed.